Topics

ERROR: initramfs-netboot-image-1.0-r0 do_rootfs: The postinstall intercept hook 'update_gio_module_cache' failed #help


Vele Tosevski
 

Hey everyone,

I am having an issue trying to build the icefish 9.0.3 AGL image for intel-corei7-64.

I am running the following scripts in my agl workspace:
  • source meta-agl/scripts/aglsetup.sh -f -m intel-corei7-64 agl-devel agl-demo agl-appfw-smack agl-netboot agl-pipewire
  • bitbake agl-demo-platform
and getting the following error: 

Initialising tasks: 100% |##########################################################################################################################| Time: 0:00:13
Sstate summary: Wanted 786 Found 354 Missed 432 Current 2226 (45% match, 85% complete)
NOTE: Executing SetScene Tasks
NOTE: Executing RunQueue Tasks
ERROR: initramfs-netboot-image-1.0-r0 do_rootfs: The postinstall intercept hook 'update_gio_module_cache' failed, details in /home/secureagl/workspace_agl/build/tmp/work/intel_corei7_64-agl-linux/initramfs-netboot-image/1.0-r0/temp/log.do_rootfs
ERROR: initramfs-netboot-image-1.0-r0 do_rootfs: Function failed: do_rootfs
ERROR: Logfile of failure stored in: /home/secureagl/workspace_agl/build/tmp/work/intel_corei7_64-agl-linux/initramfs-netboot-image/1.0-r0/temp/log.do_rootfs.21835
ERROR: Task (/home/secureagl/workspace_agl/meta-agl/meta-netboot/recipes-core/images/initramfs-netboot-image.bb:do_rootfs) failed with exit code '1'
NOTE: Tasks Summary: Attempted 7917 tasks of which 7841 didn't need to be rerun and 1 failed.

The log file mentioned has the following output:

NOTE: Installing complementary packages ...
NOTE: Running ['oe-pkgdata-util', '-p', '/home/secureagl/workspace_agl/build/tmp/pkgdata/intel-corei7-64', 'glob', '/tmp/installed-pkgsa5vev4bv', '']
NOTE: Running intercept scripts:
NOTE: > Executing update_gio_module_cache intercept ...
NOTE: Exit code 1. Output:
+ [ True = False ]
+ qemu-x86_64 -r 3.2.0 -cpu Nehalem,check=false -E LD_LIBRARY_PATH=/home/secureagl/workspace_agl/build/tmp/work/intel_corei7_64-agl-linux/initramfs-netboot-image/1.0-r0/rootfs/usr/lib:/home/secureagl/workspace_agl/build/tmp/work/intel_corei7_64-agl-linux/initramfs-netboot-image/1.0-r0/rootfs/lib -L /home/secureagl/workspace_agl/build/tmp/work/intel_corei7_64-agl-linux/initramfs-netboot-image/1.0-r0/rootfs /home/secureagl/workspace_agl/build/tmp/work/intel_corei7_64-agl-linux/initramfs-netboot-image/1.0-r0/rootfs/usr/libexec/gio-querymodules /home/secureagl/workspace_agl/build/tmp/work/intel_corei7_64-agl-linux/initramfs-netboot-image/1.0-r0/rootfs/usr/lib/gio/modules/
 
ERROR: The postinstall intercept hook 'update_gio_module_cache' failed, details in /home/secureagl/workspace_agl/build/tmp/work/intel_corei7_64-agl-linux/initramfs-netboot-image/1.0-r0/temp/log.do_rootfs
DEBUG: Python function do_rootfs finished
ERROR: Function failed: do_rootfs

I am not sure what the problem is here.  I built a qemu emulation image before which worked.  I then deleted the sstate cache and build folder and ran the above commands.  I retained the downloads folder though.

The local.conf settings enabled are maintaining a downloads folder and sstate cache.  I also have INHERIT += "rm_work" on to flush the tmp folder.

Any input would save me a ton of time.

Thanks